Witamy na GTAOnline Obecny czas to 2018-11-19, 16:38 Użytkowników: 76733
Strona główna | Użytkownicy | Grupy | Faq | Regulamin | Zaloguj

Poprzedni temat :: Następny temat
end
Autor Wiadomość

kajetan254 





Informacje
Nick w MP: Kajetan
Wiek: 21
Na forum: 430 dni
Posty: 42
Piwa: 14
Respekt: 60

Wysłany: 2018-08-26, 21:02   end



Witam, czy mógłby mi ktoś pomóc wstawić 'end' aby kod działał, error z db3: https://imgur.com/Lz046fc
Za pomoc stawiam :piwo: :D
local sound = {}

function updateEngineSound() 
    local allVehicles getElementsByType("vehicle") 
    for indexveh in ipairs (allVehicles) do 
   for _,v in pairs(getElementsByType("vehicle")) do
        local model getElementModel(veh) 
        if model ==     494 then 
     if getElementData(v"vehicle:id") == 678 then
            if getVehicleEngineState(vehthen 
                if isElement(sound[veh]) then 
                    local gear getVehicleCurrentGear veh ) or 1
                    local velocityXvelocityYvelocityZ getElementVelocity(veh) 
                    local actualspeed = ((velocityX^velocityY^velocityZ^2)^(0.5)) * ((11 gear) /10)
                    local mph actualspeed 70 111.847 
                    local minSoundSpeed 0.20 
                    local soundSpeed mph/(1000+1000/minSoundSpeed) + minSoundSpeed  
                    setSoundSpeed (sound[veh], soundSpeed) 
                else
                    local xygetElementPosition(veh)
                    sound[veh] = playSound3D("sounds/engine.wav"xyztrue)
                    attachElements(sound[veh], veh)
                end 
            else
                if isElement(sound[veh]) then
                    destroyElement(sound[veh])
                end
            end
        end 
    end 
end 
addEventHandler("onClientPreRender"rootupdateEngineSound)

local sound = {}

function updateEngineSound() 
    local allVehicles getElementsByType("vehicle") 
    for indexveh in ipairs (allVehicles) do 
        local model getElementModel(veh) 
        if model ==     502 then 
            if getVehicleEngineState(vehthen 
                if isElement(sound[veh]) then 
                    local gear getVehicleCurrentGear veh ) or 1
                    local velocityXvelocityYvelocityZ getElementVelocity(veh) 
                    local actualspeed = ((velocityX^velocityY^velocityZ^2)^(0.5)) * ((11 gear) /10)
                    local mph actualspeed 70 111.847 
                    local minSoundSpeed 0.20 
                    local soundSpeed mph/(1000+1000/minSoundSpeed) + minSoundSpeed  
                    setSoundSpeed (sound[veh], soundSpeed) 
                else
                    local xygetElementPosition(veh)
                    sound[veh] = playSound3D("sounds/engine2.wav"xyztrue)
                    attachElements(sound[veh], veh)
                end 
            else
                if isElement(sound[veh]) then
                    destroyElement(sound[veh])
                end
            end
        end 
    end 
end 
addEventHandler("onClientPreRender"rootupdateEngineSound)


Postaw piwo autorowi tego posta
 

NyAngel 





Informacje
Nick w MP: NyAngel
Wiek: 18
Na forum: 1196 dni
Posty: 124
Piwa: 322
Respekt: 66,3

Wysłany: 2018-08-26, 21:06   




local sound = {}

function updateEngineSound() 
    local allVehicles getElementsByType("vehicle") 
    for indexveh in ipairs (allVehicles) do 
   for _,v in pairs(getElementsByType("vehicle")) do
        local model getElementModel(veh) 
        if model ==     494 then 
     if getElementData(v"vehicle:id") == 678 then
            if getVehicleEngineState(vehthen 
                if isElement(sound[veh]) then 
                    local gear getVehicleCurrentGear veh ) or 1
                    local velocityXvelocityYvelocityZ getElementVelocity(veh) 
                    local actualspeed = ((velocityX^velocityY^velocityZ^2)^(0.5)) * ((11 gear) /10)
                    local mph actualspeed 70 111.847 
                    local minSoundSpeed 0.20 
                    local soundSpeed mph/(1000+1000/minSoundSpeed) + minSoundSpeed  
                    setSoundSpeed (sound[veh], soundSpeed) 
                else
                    local xygetElementPosition(veh)
                    sound[veh] = playSound3D("sounds/engine.wav"xyztrue)
                    attachElements(sound[veh], veh)
                end 
            else
                if isElement(sound[veh]) then
                        destroyElement(sound[veh])
                    end
                    end
            end 
        end 
    end
end 
addEventHandler("onClientPreRender"rootupdateEngineSound)


_________________
Wyłączny kontakt do mnie :

----------------------KONTAKT----------------------
GG : GG:52682792
STEAM : http://steamcommunity.com...561198239794308

-------------------------------------------------------
Postaw piwo autorowi tego posta
 
Tagi: end
Anonymous



Dołaczył: Wczoraj 0:00
Posty: 1
Skad: google.com


Anonymous Koniecznie zajrzyj na:







Wyświetl posty z ostatnich:   
Ten temat jest zablokowany bez możliwości zmiany postów lub pisania odpowiedzi
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Wersja do druku

Skocz do:  


phpBB by Przemo modified by xXx 2003-2016

Template GTAONLINE created by gtaonline.pl



Strona wygenerowana w 0,15 sekundy. Zapytań do SQL: 20