Witamy na GTAOnline Obecny czas to 2018-07-20, 19:54 Użytkowników: 75322
Strona główna | Użytkownicy | Grupy | Faq | Regulamin | Zaloguj

GTAONLINE.PL
Tematy otagowane jako: łączy
1. [GTAIV] Multiplayer IV:MP ciągle się łączy
Witam, tak jak w temacie gdy próbuje dołączyć na jaki kolwiek serwer w IV:MP to wbijam lecz gdy jest ta statua wolności pisze ciągle connecting to [Ip serwera]. Proszę o pomoc!!!
2. Serwer nie łączy się z bazą danych
dzien dobry,
przychodze tutaj z problemem na moim serwerze linux samp 0.3.7, otoz nie chce on sie polaczyc z serwerem! nie wiem w czym jest problem, wiec tutaj pisze. serwer jest postawiony na skrypcie ms-rp (mysantos). do samego gamemoda sa dolaczone includes i modules, w modules jest plik w ktorym powinno sie ustawiac te dane do bazy, wpisuje je na milion procent dobrze, w mysql_log wyskakuje nadal to samo;
[code][08] >> mysql_connect( )
[08] CMySQLHandler::CMySQLHandler() - constructor called.
[08] CMySQLHandler::CMySQLHandler() - Connecting to "127.0.0.1" | DB: "db" | Username: "user" ...
[08] CMySQLHandler::Connect() - Can't connect to MySQL server on '127.0.0.1' (111) (Error ID: 2003)
[08] >> mysql_set_charset( Connection handle: 1 )
[08] CMySQLHandler::SetCharset() - You cannot call this function now. (Reason: Dead Connection)
[08] >> mysql_query( Connection handle: 1 )
[08] CMySQLHandler::Query() - You cannot call this function now. (Reason: Connection is dead)
[08] >> mysql_query( Connection handle: 1 )
[/code]

na dodatek gdy zrobie nowa baze na localhoscie(wpisuje 127.0.0.1) to jest to samo...
tu jest jakis kawalek z gamemoda;
[code]}
public OnGameModeInit()
{
mysql_debug(1);

if(mysql_connect(SQL_HOST, SQL_USER, SQL_DB, SQL_PASSWORD))
{
print("Połączenie z bazą SQL poprawne.");

// Charset, gamemode
mysql_set_charset("utf-8");
SetGameModeText("xxx&...
3. [PHP] MTA PHP SDK - Nie łączy
Witam próbowałem zrobić funkcję, która wyświetli mi pewne informacje z serwera na stronie, ale mta_sdk.php nie może połączyć mi się z serwerem.

Port http otwarty, użytkownik którego używam do połączenia ma wymagane prawa i pomimo tego nie śmiga.

Błąd jaki mi wyrzuca:
Kod:

Fatal error: Uncaught exception 'Exception' with message 'Could not connect to ip:20145' in
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php:146 Stack trace: #0
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php(79): mta->do_post_request('ip', 20145, '/php/call...', '') #1
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php(257): mta->callFunction('php', 'getPlayersOnlin...', Array) #2
/home/users/XXX/public_html/YYY/mta_php_sdk/mta.php(38): Resource->call('getPlayersOnlin...') #3 {main} thrown in
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php on line 146



Połączenie wygląda tak:
Kod:


<?php
include( "mta_sdk.php" );

$mtaServer = new mta( "ip", 20145, "mta_php_sdk", "password" );
$resource = $mtaServer->getResource ( "php" );
$return = $resource->call ( "getPlayersOnline" );

?>


Wie ktoś w czym leży problem?
Dodam, że używając SDK w drugą stronę czyli przez callRemote z serwera MTA wszystko pięknie śmiga.
4. Mysql nie łączy
witam mam takowy problem , gdy wpisuje w konsoli serwera start db2 oraz start ogrpg-db
Wyskakuje następujący problem
[2016-12-18 18:02] start: Requested by Console
[2016-12-18 18:02] WARNING: ogrpg-db requires upgrade as min_mta_version> section in the meta.xml is incorrect or missing (expected at least server 1.5.2 because of 'dbPrepareString')
[2016-12-18 18:02] Use the 'upgrade' command to perform a basic upgrade of resources.
[2016-12-18 18:02] Starting ogrpg-db
[2016-12-18 18:02] WARNING: [skrypty_glowne]/ogrpg-db/s_db.lua:33: Bad usage @ 'dbConnect' [Access denied for user 'db_20940'@'n8249h130.sprintdatacenter.net' (using password: YES)]
[2016-12-18 18:02] INFO: * No Connecting to server MYSQL..
[2016-12-18 18:02] ERROR: [skrypty_glowne]/ogrpg-db/s_db.lua:54: attempt to call global 'mysql_connect' (a nil value)
[2016-12-18 18:02] start: Resource 'ogrpg-db' started
> start db2
[2016-12-18 18:02] start: Requested by Console
[2016-12-18 18:02] Starting DB2
[2016-12-18 18:02] WARNING: [skrypty_glowne]/DB2/sql.lua:16: Bad usage @ 'dbConnect' [Can't connect to MySQL server on '3rdp.serverproject.pl' (111)]
[2016-12-18 18:02] BRAK POLACZENIA Z BAZA DANYCH!
[2016-12-18 18:02] start: Resource 'db2' started

Dodam iż wszystko dobrze mam edytowane (tak mi sie wydaje)
5. nie łączy z mapa
ELo. mam juz hosting wsystko itd ale mapy mi nie chce czytac..
[21] Script[gamemodes/PCS2.amx]: Run time error 19: "File or function is not found"
[21] Number of vehicle models: 0
pomoże ktos?
6. [MYSQL]Nie łączy
Witam, dziś kupiłem VPS.
Parametry:
Procek: 4x 3.0 GHZ
RAM: 6gb
DYSK SSD: 75GB
Pamięć SWAP: 512
Miejscowość: Poznań
Panel zarzo: HyperVM

Gdy zainstalowałem GM i połączyłem z MySQL nie połączyło mi bazy danych wywaliło mi błąd:



    DBHandler=dbConnect("mysql""dbname="..DBName..";host="..DBHost..""DBUserDBPass"share=1")


Dane są na 200% dobrze połączone.

Z góry THX za pomoc stawiam :piwo:
7. Nie łączy ze serwerem
Jak chce wejść na jakiś byle jaki serwer to pisze "Conneting to <<IP SERWERA>>" i nic.. stoi tak, od wczoraj to mam co robić?




phpBB by Przemo modified by xXx 2003-2016

Template GTAONLINE created by gtaonline.pl



Strona wygenerowana w 0,05 sekundy. Zapytań do SQL: 10