Witamy na GTAOnline Obecny czas to 2018-04-23, 19:14 Użytkowników: 74297
Strona główna | Użytkownicy | Grupy | Faq | Regulamin | Zaloguj

GTAONLINE.PL
Tematy otagowane jako: file
1. Dini i File
Witam, gdy dodam do callbacka OnGameModeInit to:
Cytat:

if(dini_Exists("HeadAdmin.ini"))
{
dini_Get("HeadAdmin.ini","Nick", PlayerName(playerid));
}
else
{
print ("=");
print ("Stworzono plik HeadAdmin.ini");
print ("=");
dini_Create("HeadAdmin.ini");
}


To otrzymuję bardzo dziwne błędy:
Cytat:

C:UsersLukiDesktopSerwer PASpawnoincludedini.inc(32) : error 017: undefined symbol "fexist"
C:UsersLukiDesktopSerwer PASpawnoincludedini.inc(40) : error 017: undefined symbol "fexist"
C:UsersLukiDesktopSerwer PASpawnoincludedini.inc(42) : error 017: undefined symbol "io_write"
C:UsersLukiDesktopSerwer PASpawnoincludedini.inc(194) : error 017: undefined symbol "io_read"
C:UsersLukiDesktopSerwer PASpawnoincludedini.inc(197) : error 035: argument type mismatch (argument 2)


Od razu mówię że w linicje 32, 30, 42 nie mam żadnego z tych tekstów ponieważ te linijki to:

Cytat:

32: #if defined FILTERSCRIPT
40: }
42: public OnFilterScriptExit()


Gdzie kolwiek to dodam to mam takie błędy (identyczne)
2. File or function is not found...
Witam otóż mam popularny już problem File or function is not found oraz błąd przy ładowaniu pluginu mysql pewnie dlatego sie tak dzieje. Jednakże mniej więcej udało mi sie dojść dlaczemu tak sie dzieje i wnioski są takie mam 2 pluginy mysql i w jednym nie działa jedna rzecz w drugim druga i tak include a_samp wyrzuca błędy mysql_query i mysql_init w sesie undefined symbol ale nie wywala błędu w konsoli a samo <mysql> nie wywala błędów w mapie ale wyskakuje to badziewie w temacie no i tak mam ten include <mysql> ale bez pluginu do niego bo linki juz z 200 lat nie działają nie wiem czemu dzieją się takie cuda z tym <a_mysql> bo zawsze miałem z tym problem. Ktoś ma pojęcie co tu sie odjaniepawla?
3. Invalid/unsupported P-code file format
Otóż sprawa wygląda tak.

Mam skrypt robiony od podstaw i ostatnia kompilacja nastąpiła dziś i wystąpil błąd w konsoli :
Kod:


SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[12:58] filterscripts = "" (string)
[12:58]
[12:58] Server Plugins
[12:58] --------------
[12:58] Loaded 0 plugins.

[12:58]
[12:58] Filterscripts
[12:58] ---------------
[12:58] Loaded 0 filterscripts.

[12:58] Script[gamemodes/grandlarc.amx]: Run time error 17: "Invalid/unsupported P-code file format"
[12:58] Failed to load 'gamemodes/grandlarc.amx' script.
[12:58] Number of vehicle models: 0
[13:04] --- Server Shutting Down.


I sam niewiem o co chodzi.. plik .amx odziwo posiada 0kb oraz żadnej zawartości ale czym to jest spowodowane to niewiem. Domyślne skrypty normalnie można skompilować zawartość jest bajty są domyślne skrypt się ładuje.. Ale mój niestety nie..

Mam nadzieje że nie trzeba będzie pisać skryptu od nowa -.-

Za pomoc daje :piwo:
4. I can't open the savepositions.txt file for append
Witam. Otóż od niedawna mam pewien problem z plikiem, w którym zapisywane są pozycje z samp'a [chodzi o te z komendy /save]. Podczas, gdy chcę zapisać jakąś pozycje, wyskakuje mi takie cuś "I can't open the savepositions.txt file for append".
Szukałem pomocy na forum samp'a, ogółem we wszystkich tematach z tym związanym w internecie. Próbowałem przeinstalowania samp'a, gta, sam tworzyłem plik "savepositions.txt" [próbowałem również tej 'drugiej opcji': savedpositions.txt] i nic, dalej ten sam błąd. Wyczytałem gdzieś również, że przyczyną może być ograniczanie uprawnień dla aplikacji samp [że nie może tworzyć, ani otwierać plików z zewnątrz], zmniejszyłem więc uprawnienia/zabezpieczenia i dalej kupa. Czy ktoś byłby w stanie pomóc ?
5. File or Function not found
Siema przy starcie serwera wywala mi błąd taki jak w temacie w konsoli wyskakuje również błąd z ładowaniem plugina mysql dodam że plugin wpisany jest w cfg i dodany do folderu plugins tak samo jak include, w mapie nie ma żadnych błędów. Macie może jakieś sugestie?
6. [INNE] Włączenie serv'a. File or function is not found
Nie będę się rozpisywał, po włączeniu serwera domówki, mam takie coś.

[code]
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3e, (C)2005-2012 SA-MP Team

[18:41:05] filterscripts = "" (string)
[18:41:05]
[18:41:05] Server Plugins
[18:41:05] --------------
[18:41:05] Loading plugin: streamer
[18:41:05]

*** Streamer Plugin v2.6 by Incognito loaded ***

[18:41:05] Loaded.
[18:41:05] Loading plugin: sscanf
[18:41:05]

[18:41:05] ===============================

[18:41:05] sscanf plugin loaded.

[18:41:05] (c) 2009 Alex "Y_Less" Cole

[18:41:05] ===============================

[18:41:05] Loaded.
[18:41:05] Loading plugin: audio
[18:41:05]

*** Audio Plugin v0.5 by Incognito loaded ***

[18:41:05] Loaded.
[18:41:05] Loading plugin: mysql
[18:41:05]

> MySQL plugin R4-2 successfully loaded.

[18:41:05] Loaded.
[18:41:05] Loading plugin: fm
[18:41:05] ******************
[18:41:05] ** FILE MANAGER **
[18:41:05] ** Loaded **
[18:41:05] ** Version 1.1 **
[18:41:05] ******************
[18:41:05] Loaded.
[18:41:05] Loaded 5 plugins.

[18:41:05]
[18:41:05] Filterscripts
[18:41:05] ---------------
[18:41:05] Loaded 0 filterscripts.

[18:41:05] Script[gamemodes/aa.amx]: Run time error 19: "File or function is not found"
[18:41:05] Number of vehicle models: 0
[/code]
Zawsze działa...




phpBB by Przemo modified by xXx 2003-2016

Template GTAONLINE created by gtaonline.pl



Strona wygenerowana w 0,06 sekundy. Zapytań do SQL: 10