Witamy na GTAOnline Obecny czas to 2017-01-23, 07:29 Użytkowników: 68175
Strona główna | Użytkownicy | Grupy | Faq | Regulamin | Zaloguj

GTAONLINE.PL
Tematy otagowane jako: nie
1. Nie mogę wejść na forum z mojego ynternetu
Tak jak w temacie coś się popsuło i nie mogę wejść na forum z mojego internetu. Wyskakuje mi błąd taki: 403 Forbidden you dont have permission to Access this document. Ktoś wie o co chodzi? Aktualnie jestem na mobilnym.
2. Nie dziala DM
Siema Nie działą Mi dm pisałem już posta ale musze szybko odp
Nwm czm wszystko jest false -- Przy kazdym wejsciu i wyjsciu ustawia maksymalna liczbe slotow na ilosc aktualnych graczy + 10% z maksymalnej ilosci slotow, zrobione przez Bone
function dynamiczne()
local maks_graczy = getServerConfigSetting ( "maxplayers" )
local teraz_graczy = #getElementsByType( "player" )
local nowe = math.ceil( teraz_graczy + (tonumber(maks_graczy) * 0.2) )
if tonumber(nowe) < tonumber(maks_graczy) then
setMaxPlayers(nowe)
else
setMaxPlayers(tonumber(maks_graczy))
end
end

addEventHandler("onPlayerQuit",root,dynamiczne)
addEventHandler("onPlayerJoin",root,dynamiczne)

--[[addEventHandler("onPlayerConnect", getRootElement(), function (nick, ip, username, serial)
local q = exports.rpg_mysql:mysql_query("SELECT * FROM rpg_serials WHERE serial=?", serial)
if #q < 1 then
cancelEvent(true, "Nie jesteś zautoryzowany do wejścia na ten serwer !")
end
end)--]]

addEvent("core:spawnPlayer", true)
addEventHandler("core:spawnPlayer", root, function()
local pos=getElementData(source,"player:spawn")
if not pos then return end
fadeCamera(source, true)
spawnPlayer(source, pos[1], pos[2], pos[3])
setCameraTarget(source,source)
toggleControl(source,"fire", false)
toggleControl(source,"aim_weapon", false)
local load=loadPlayerData(source)
if ...
3. [PHP] MTA PHP SDK - Nie łączy
Witam próbowałem zrobić funkcję, która wyświetli mi pewne informacje z serwera na stronie, ale mta_sdk.php nie może połączyć mi się z serwerem.

Port http otwarty, użytkownik którego używam do połączenia ma wymagane prawa i pomimo tego nie śmiga.

Błąd jaki mi wyrzuca:
Kod:

Fatal error: Uncaught exception 'Exception' with message 'Could not connect to ip:20145' in
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php:146 Stack trace: #0
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php(79): mta->do_post_request('ip', 20145, '/php/call...', '') #1
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php(257): mta->callFunction('php', 'getPlayersOnlin...', Array) #2
/home/users/XXX/public_html/YYY/mta_php_sdk/mta.php(38): Resource->call('getPlayersOnlin...') #3 {main} thrown in
/home/users/XXX/public_html/YYY/mta_php_sdk/mta_sdk.php on line 146



Połączenie wygląda tak:
Kod:


<?php
include( "mta_sdk.php" );

$mtaServer = new mta( "ip", 20145, "mta_php_sdk", "password" );
$resource = $mtaServer->getResource ( "php" );
$return = $resource->call ( "getPlayersOnline" );

?>


Wie ktoś w czym leży problem?
Dodam, że używając SDK w drugą stronę czyli przez callRemote z serwera MTA wszystko pięknie śmiga.
4. Samochody się nie psują :/
local function pojazdPusty(veh)
if 
not veh then return end
    local occupants 
getVehicleOccupants(veh)
    
local seats getVehicleMaxPassengers(veh)
    if (
not seatsthen return true end
    
for i=0,seats do
    
local occupant occupants[seat]
    if 
occupant and (getElementType(occupant)=="player" or getElementType(occupant)=="ped") and getPedOccupiedVehicleSeat(occupant) == i then
        
return false
    end
    end
    
return true
end


for i,v in ipairs(getElementsByType("vehicle")) do
    if (
pojazdPusty(v)) then
        setVehicleDamageProof
(v,true)
    else
    if 
getElementData(v,"damageproof"then setVehicleDamageProof(vtrue) return end
    setVehicleDamageProof
(v,false)
    
end
end

addEventHandler 
"onVehicleEnter"root, function()
if 
source then
    
if getElementData(source,"damageproof"then setVehicleDamageProof(sourcetrue) return end
    setVehicleDamageProof
(sourcefalse)
    
end
end
)

addEventHandler "onVehicleExit"root, function()
    if 
source then
    
if (pojazdPusty(source)) then
        setVehicleDamageProof
(sourcetrue)
    else
        if 
getElementData(source,"damageproof"then setVehicleDamageProof(sourcetrue) return end
        setVehicleDamageProof
(sourcefalse)
    
end
    end
end
)


Chciałem, żeby samochody się nie paliły, nie wybuchały, ale teraz wcale się nie psują.. Za pomoc stawiam :piwo: .
5. Gui się nie ukrywa.
local informacjaPickup createPickup(-1964.86121436.8927635.1718831239)

function 
informacje(player)
    
guiSetVisible (memkotrue)
    
memko guiCreateMemo (555231255270"Informacja"falsememko)
end
addEventHandler
("onClientPickupHit"informacjaPickupinformacje)

function 
chowanie(player)
    
guiSetVisible(memkofalse)
end
addEventHandler
("onClientPickupLeave"informacjaPickupchowanie)


Gui pojawia się, a pózniej ukrywa.
Drugi raz pojawia się, ale nie znika.
Za pomoc stawiam :piwo: .
6. Gui się nie pojawia.
Czy mógłby mi ktoś pomóc z tym kodem?
local informacjaPickup createPickup(-1964.86121436.8927635.1718831239)

function 
informacje(player)
    
guiCreateWindow (582168233306"Informacja"trueplayer)
    
guiCreateMemo (1027213269"Informacja"trueplayer)
end
addEventHandler
("onPickupHit"informacjaPickupinformacje)

Po wejściu w pickup nie pojawia mi się okno, ale w debugscript 3 nie pojawia się też żaden błąd.
Czy mógłby mi ktoś pomóc z tym skryptem?
Stawiam :piwo: !
7. Nie działa skrypt MTA:SA. :C
Dlaczego nie działa mi ten kod?
Cała funkcja chat działa, lecz mam problem z funkcją 'naprawa',
Proszę o pomoc, stawiam :piwo:
Z góry dzięki! :)

[lua]--Autorem skryptu jest Kuksisko
--Zakaz używania całego bądź fragmentu kodu, skrypt tworzony dla serwera SAN FIERRO RPG - MTA SAN ANDREAS.


--lokalizacje
local lok1 = createBlip( -2026.77625, 173.70081, 28.23794, 27 ) --Mechanik Doherty
--koniec

--markery
local mar1 = createMarker (-2034.73889, 170.06284, 28.24562 - 1, "cylinder", 3.5, 0, 82, 92)
--koniec


function chat (hitElement, matchingDimension)
if ( hitElement ) then
if isPlayerInVehicle ( hitElement ) then
outputChatBox ( "Jeżeli chcesz naprawić pojazd wpisz /napraw.nnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnNaprawisz wtedy cały pojazd. #0066FF(koszt: 130EUR.)", hitElement, 0, 255, 0, true )
else
outputChatBox ( "Musisz być w pojeździe!", hitElement, 255, 0, 0, true )
end
end
end
addEventHandler ( "onMarkerHit", mar1, chat )

function naprawa ( playerSource )
if (playerSource) then
if isElementWithinMarker(playerSource, mar1) then
local kasa = getPlayerMoney ( playerSource )
if ( kasa > 129 ) then
takePlayerMoney ( playerSource, 130 )
fixVehicle ( playerSource )
outputChatBox ( "Pojazd został naprawiony!", playerSource )
else
outputChatBox ( "Nie posiadasz pieniędzy na naprawę pojazdu!" )
end
end
end
end
addCommandHand...
8. Nie moge włączyć serwera po wgraniu skryptów ???
Nie moge włączyć serwera po wgraniu paczki YAD na poprzedniej wersji Serwerproject i MTA działała a teraz tej paczki nie moge odpalic . Serwer ładuje się przez chwilę i się nie włącza .
9. Nie działa skrypt. MTA:SA
local czlowiek createPed(251, -1485.19910806.904057.1853290)
local skrim createMarker (-1486.47473 1.5806.883796.78710 0.5"cylinder"32552552550)


function 
testowySkrypt sourcePlayercommandNamethePlayerhitElement )
    
local sprawdz getPlayerFromNick thePlayer )
    if ( 
sprawdz then
        
if isPlayerInVehicle sprawdz then
            outputChatBox 
checkedPlayerName .. ", najpierw musisz wysiąść z pojazdu!"sourcePlayer )
        else
            
outputChatBox "Skrypt w fazie testów."sourcePlayer )
        
end
end
addEventHandler 
("onMarkerHit"skrimtestowySkrypt)


Dlaczego nie działa mi ten skrypt?
Proszę o pomoc, jestem nowy w LUA. Stawiam :piwo: za pomoc! :)
10. Przesłanie graczowi pieniędzy gdy nie ma w grze.
Czy istnieje taka możliwość? ElementDaty nie ustawie, bo nie ma jak gracza pobrać do kodu tak samo jak przypisać kwoty do konta gracza. Więc w jaki sposób mogę to zrobić? Piwo za pomoc.
11. Gui coś nie tak z dialogid
Witajcie!
W komendzie /zaladuj dałem:
Pawn
ShowPlayerDialog(playerid80DIALOG_STYLE_LIST"Lista towarów""LegalnenNielegalnenVIPnSpecialne""Wybierz""");

Dałem w taki dialog:
Pawn

if(dialogid == 80)
{
if(
response)
{
switch(
listitem)
{
case 
0:
{
ShowPlayerDialog(playerid81DIALOG_STYLE_LIST"Legalne""Patyki 1 score 1000$nKamienie 1 score 1000$nWoda 1 score 1000$nPiasek 1 score 1000$""OK""Wyjdz");
}
case 
1:
{
ShowPlayerDialog(playerid82DIALOG_STYLE_LIST"NieLegalne""rara 2 score 5.000$n ""Wybierz""");
}
}
}
return 
1;
}

i nie wbija mi gdy kliknę 1 opcję w /zaladuj czyli legalne do tego dialogid.
Wydaje mi się wszystko dobrze ale pewnie gdzieś jest błąd. Pomożecie? Stawiam piwwo i rep
12. jak wchodzę w marker skinów dla frakcji nie daje go
Witam mam taki problem bo jak wchodzę w marker skinow dla frakcji to mi go nie daje a jestem we frakcji umiał by ktoś pomóc w tym kodzie? był bym bardzo wdzięczny

http://wklej.org/id/3014700/
13. onClientPreRender nie ładuje nowych klatek
Witam. Mam sobie taki skrypcik na hud który musi być podpięty pod onClientPreRender ,ponieważ wymaga zmiany gdy np. gracz skoczy z dużej wysokości i straci hp. Jednak jest inaczej, ładuje skrypt ale klatki nowe nie ładują się, mogę sobie skakać do śmierci z dużej wysokości i hp mam 100 na 100 (dopóki nie zrobie refresha)

Skrypt:

local krew 
math.floor (getElementHealth getLocalPlayer() ))
local sxsy guiGetScreenSize()
czcionkadxCreateFont(  "jaapokkisubtract-regular.ttf"10 )

function 
dx2()
  
dxDrawText("Krew: "..krew.."/100",sx*(1040/1280),sy*(87/1024),sx*(315/1280),sy*(28/1024), tocolor(255255255255), 1.00czcionka"left""top"falsefalsefalse,false,false)
 
end
 addEventHandler
("onClientPreRender",getRootElement(),dx2)


Ktoś coś ? ,bo wydaje mi się że dobrze kod jest napisany a jak nie będzie wyjścia to mam przygotowany zastępczy kod ,ale bardziej zależy mi na tym. Pozdrawiam :)
14. Rejestracja w MySQL nie działa
R* Witam, otóż nie dziala mi, system rejestracji i logowania, bo gdy przy rejestracji ustalimy hasło np, "12345" to do konta będzie pasowało każde inne hasło.
Prosze o pomc :(

Oto kod:
[code]
#include <a_samp>
#include <zcmd>
#include <kolory>
#include <sscanf>
#include <mysql>

enum E_PLAYER
{
pUID,
pName[24],
pPassword[24],
pMoney,
pScore,
Float:pHealth,
Float:pArmour,
pSkin,
pRanga
}

new PlayerCache[MAX_PLAYERS][E_PLAYER];
/*********************DIALOGI*******************/
#define D_LOGIN 1
#define D_REGISTER 2
/***********************************************/

public OnGameModeInit()
{
mysql_init(LOG_ONLY_ERRORS);
mysql_connect("XXXX", "XXXX", "XXXX", "XXXX");
return 1;
}

public OnPlayerConnect(playerid)
{
PlayerLogin(playerid);
TogglePlayerSpectating(playerid, true);
return 1;
}

public OnPlayerDisconnect(playerid, reason)
{
PlayerLogout(playerid);
return 1;
}

public OnDialogResponse(playerid, dialogid, response, listitem, inputtext[])
{
if(dialogid == D_LOGIN)
{
if(strlen(inputtext) > 0)
{
if(!strcmp(PlayerCache[playerid][pPassword], inputtext, false))
{
TogglePlayerSpectating(playerid, false);
SpawnPlayer(playerid);
}
else
{
ShowPlayerDialog(playerid, D_LOGIN, DIALOG_STYLE_PASSWORD, "{11d621}Logowanie", "{EB0000} Hasło nieprawidłowe !n {FFFFFF}Podaj hasło ...
15. nie mogę zakładać skinów frakcji
dodałem się do frakcji mam lidera 99 ale napotkałem kolejny problem gdyż nie mogę zakładać skinów frakcji a pojazdami frakcji normalnie mogę jeździć tu podaje link do kodu proszę o szybką odpowiedź wklej.org/id/3010578
16. mysql ogrpg_users nie istnieje
Witam w konsolce wyskakuje mi taki błąd jak to naprawić?

[2017-01-08 23] WARNING: [pystories]/[skrypty-glowne]/ogrpg-db/s_db.lua:25: dbPoll failed; Table '605582_test.ogrpg_users' doesn't exist

moje setting's w bd


-- Settings
DBHandler=nil
DBName="605582_test"
DBUser="605582"
DBPass="*********"
DBHost="sql.pukawka.pl"
17. Zapis koloru auta i komendy admina nie działają
Witam, chciałbym prosić o pomoc w dwóch sprawach.

Pierwsza to brak zapisu drugiego koloru np. pomalowałem auto na niebiesko-czerwony to po restarcie skryptu pojazd ma niebiesko-czarny kolor. Co dodać aby kolory się zapisywały?

Drugą rzeczą w jakiej chciałbym prosić o pomoc są komendy na teleport auta. W temacie było napisane, że trzeba zmienić elementdaty pod swój system pojazdów. Tak też zrobiłem, ale podczas wpisania komendy nic się nie dzieje. debugscript 3 też nie pokazuje żadnych błędów.

Próbowałem już kilku rzeczy, ale żadna z nich nie dawała skutku dlatego zwracam się do Was z pomocą. Za pomoc daję :piwo: i R*
Plik zapisu aut
[lua]handler = dbConnect("sqlite", "pojazdy.db")

--pojazdy
dbExec(handler, "CREATE TABLE IF NOT EXISTS pojazdy (id INTEGER PRIMARY KEY AUTOINCREMENT, wlasciciel TEXT, model INTEGER, x FLOAT, y FLOAT, z FLOAT, rot FLOAT, ca INTEGER, cb INTEGER, cc INTEGER, przebieg FLOAT, paliwo FLOAT)")
dbExec(handler, "CREATE UNIQUE INDEX IF NOT EXISTS IDX_id on pojazdy(id)")

--tuning
dbExec(handler, "CREATE TABLE IF NOT EXISTS tuning (id INTEGER, t0 INTEGER, t1 INTEGER, t2 INTEGER, t3 INTEGER, t4 INTEGER, t5 INTEGER, t6 INTEGER, t7 INTEGER, t8 INTEGER, t9 INTEGER, t10 INTEGER, t11 INTEGER, t12 INTEGER, t13 INTEGER, t14 INTEGER, t15 INTEGER, t16 INTEGER, paintjob INTEGER, hr INTEGER, hg INTEGER, hb INTEGER)")
--dbExec(handler, "CREATE UNIQUE INDEX IF NOT EXISTS IDX_id on tuning(id)&qu...
18. Dlaczego nie eksploduje?
Co w tym trzeba poprawić, aby wybuchało?

W db nic nie ma.


mina
={} 



addCommandHandler("mina",function(plr
local x,y,z=getElementPosition(plr
setPedAnimation (plr,"BOMBER","BOM_Plant"
setTimer (setPedAnimation,1500,1,plr,false 
local x,y,getElementPosition(plr
setTimer(function() 
ob=createObject(1953,x,y,z-1
mina[plr]=createMarker(x,y,z-1,"cylinder",2,255,255,255,0
setElementData(mina[plr],"mina",getPlayerName(plr)) 
attachElements(ob,mina[plr]) 
end,1500,1
outputChatBox("*Rozstawiłeś(aś) minę, uważaj na nią!",plr,255,255,255
end


addEventHandler("onMarkerHit",root,function(e
if 
getElementData(source,"mina"then 
if getElementType(e)=="player" then 
if getElementData(source,"mina")==getPlayerName(ethen return end 
local x
,y,z=getElementPosition(e
createExplosion(x,y,z,3
if 
getPlayerFromName(getElementData(source,"mina")) then 
outputChatBox
("*Gracz "..getPlayerName(e).." wszedł na Twoją minę!",getPlayerFromName(getElementData(source,"mina")),255,255,255
end 
for _,v in ipairs(getAttachedElements(source))do 
destroyElement(v
end 
destroyElement
(source
end 
end 
end
)
19. [MYSQL] Mysql nie aktualizuje dan
Witam tak jak w temacie może ktoś kto się troche zna na pawn i na mysql by pomógł, ogólnie chodzi o to że mam stocka w ktorym sa zawarte info o tym co ma sie dziac jak gracz wyjdzie z serwa i wyglada to tak

https://scr.hu/09kz5D

I nic cisza po wyjsciu z serwa w bazie nic sie nie zmienia a raczej działa poniewaz mam jeszcze stocki do logowania i rejestracji i wszystko hula jak na razie
20. Konsola nie wczytuje GM'a
Witam, mam problem.
Otóż stworzyłem skrypt według poradnika Sim00na na YT z bazą danych.

Wszystko cacy, ale nie wczytuje mi skryptu
Logi z konsoli :
[code]
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7, (C)2005-2015 SA-MP Team

[17:54:39]
[17:54:39] Server Plugins
[17:54:39] --------------
[17:54:39] Loading plugin: sscanf
[17:54:39]

[17:54:39] ===============================

[17:54:39] sscanf plugin loaded.

[17:54:39] (c) 2009 Alex "Y_Less" Cole

[17:54:39] 0.3d-R2 500 Players "dnee"

[17:54:39] ===============================

[17:54:39] Loaded.
[17:54:39] Loading plugin: streamer
[17:54:39]

*** Streamer Plugin v2.8.2 by Incognito loaded ***

[17:54:39] Loaded.
[17:54:39] Loading plugin: mysql
[17:54:39]

> MySQL plugin R5 successfully loaded.

[17:54:39] Loaded.
[17:54:39] Loaded 3 plugins.

[17:54:39]
[17:54:39] Filterscripts
[17:54:39] ---------------
[17:54:39] Loading filterscript 'TextDrawEditor1.0.amx'...
[17:54:39]
--------------------------------------
[17:54:39] Text Draw Editor 1.0RC2 by Zamaroht for SA-MP 0.3 Loaded.
[17:54:39] --------------------------------------

[17:54:39] Loaded 1 filterscripts.

[17:54:39] Script[gamemodes/mysql.amx]: Run time error 19: "File or function is not found"
[17:54:39] Number of vehicle models: 0
[/code]

[ Dodano : 20...
21. Nie działaja komendy /k /zpj /b wiecie o co chodzi?
prosze o szybka pomoc proszę
22. Nie wyświetla koloru
function cos ()
outputChatBox ("#0000ffJakiś tam tekst.",_,_,_,true)
end
setTimer ( cos, 10000, 0)

Dlaczego nie wyświetla tego na kolorowo? Moim zdaniem powinno być dobrze.
23. XyzzyRP - Nie rozumiem
Juz mam tego dosc, wiele probowalem metodami prob i bledow ale nie da sie! Mianowicie mam problem ze slawnym GM XyzzyRP, jak dodac rozne rzeczy do tuningu? Domyslnie jest tylko zest. Hydrauliczny i Koła, jak dodac np... wloty? Albo spoilery? Nitro? Postanowilem sie was spytac...
24. Nie działą notifikacja.
Mam pytanie bo chciałem to przerobić na notifickacje ale jak włączyłem notifikacje to nie działa jestem zielony więc proszę o pomoc w przerobienu tego. Stawiam :piwo:



[lua]
--[[
Skrypt pisany dla serwisu GTAO.pl
Autor: marcin778 ,barcioo , Juran
w jedeniej w funkcji pomógł Haze :)
System jest pod ogrpg można edytować jak się podoba
Zakaz udostepnia na innych forach
Zakaz zmiany autora.
--]]



-- Tabela jest skończona w 65%
local niedozwolone = { -- w ostatnim rekordzie nie dawać przecinka po true lub false
[524] = true, --cement truck
[532] = true,
[519] = true, --shamal
[577] = true, -- At-400
[592] = true, --adromeda
[433] = true,
[511] = true,
[590] = true,
[431] = true,
[437] = true,
[593] = true,
[486] = true,
[406] = true,
[573] = true,
[455] = true,
[537] = true,
[569] = true,
[425] = true,
[520] = true,
[493] = true,
[595] = true,
[417] = true,
[403] = true,
[444] = true,
[556] = true,
[557] = true,
[553] = true,
[443] = true,
[432] = true


}

local lawety = {
{"policja", -2684.84961,-240.81404,7.44664,6,67,113},
{"...", 2472.17432,-1663.28931,13.32395+0.5,0,0,0}
}


local ID_LAWETY = 578
local colspheres = {}
local attX, attY, attZ = 0, -1.2, 0.5

for k, v in ipairs(lawety) do
local laweta = creat...
25. Domki nie działają
Witam, mam na serwerze taki mały problem. Na serwerze mam skrypt lss-domy i w MySql w tabeli lss_domy mam wszystkie domki, lecz na serwerze wogóle tych domków nie ma. Nie wiem w czym problem :/ Dodam jeszcze ze w konsoli wyskakuje mi to:
[2017-01-01 01:44] INFO: Zaladowano zmienionych domow: 0
26. Nie wczytuje danych z bazy danych
Witajcie, mianowicie od dwóch dni borykam się z problemem dot. wczytania danych z phpmyadmin, także. Może Wy mi pomożecie, bo mi pomysły wysiadły. Kolega mówił, że jest coś źle w dialog_login_mysql, aczkolwiek nie mam pojęcia. Nie mogę się doszukać problemu.

[spoiler]
case DIALOG_LOGIN_MYSQL:
{
if(response)
{
new data[1028];
mysql_real_escape_string(inputtext, inputtext);
if(strlen(inputtext) >= 24 || strlen(inputtext) <= 0)
{
ShowPlayerDialog(playerid, DIALOG_LOGIN, DIALOG_STYLE_PASSWORD, "Panel Logowania", "Wprowadź hasło do konta, aby wejść do gry.nn{FF0000}* Wprowadziłeś nieprawidłowe hasło do tego konta.", "Zaloguj", "Wyjdź");
return 1;
}

new str2[256];
format(str2, sizeof(str2),"SELECT player_uid, admin FROM fc_players WHERE player_password = MD5('%s') AND player_uid = '%d' LIMIT 1", inputtext, PlayerCache[playerid][UID]);
mysql_query(str2);


mysql_store_result();
if(mysql_fetch_row_format(data, "|"))
{
//LoginPlayer(playerid);
new query[1028], str[512], result[300];
format(str, sizeof(str),"SELECT * FROM `fc_players` WHERE `player_uid` = '%d' LIMIT 1", PlayerCache[playerid][UID]);
mysql_query(str);
mysql_store_result();
if(mysql_fetch_row_format(query, "|"))
{
sscanf(result, &q...
27. Nie pobiera pieniedzy
Witam mam problem chodzi o to ze Cofanie przebiegu dzała wszystko tylko nie zabiera pięniędzy graczowi co montuje

[lua]


cenazakilo=10
local guiopened = createMarker(137.36, -336.59, 0.98, "cylinder", 2.5, 255, 0, 0, 125)
local text=createElement("text")
setElementData(text, "scale", 1.7)
setElementData(text, "name", "Zerowanie przebiegun1 KM: 12 PLN")
setElementPosition(text, 1001.84, -1359.05, 13.32)
--local text=createElement("text")
--setElementData(text, "scale", 1.4)
--setElementData(text, "name", "Cennik usług:nNitro - 400.000PLNnUS1 - 100.000PLNnUS2 - 250.000PLNnPaintJob - 30.000PLNnnMaskowanie;nCałe; 400.000PLNnPołowa; 200.000PLN")
--setElementPosition(text, -1791.40, 1206.90, 25.13)
--local text=createElement("text")
--setElementData(text, "scale", 1.2)
--setElementData(text, "name", "Cennik usług (neony):nNeon czerwony - 1.000.000PLNnNeon niebieski - 1.000.000PLNnNeon zielony - 1.000.000PLNnNeon żółty - 1.000.000PLNnNeon różowy - 1.000.000PLNnNeon biały - 500.000PLN")
--setElementPosition(text, -1781.90, 1208.88, 25.13)
createObject ( 2737, -1781.90, 1209.18, 25.13, 0.00, 0.00, 0 )
createObject ( 2737, -1791.65, 1207.13, 25.13, 0.00, 0.00, 90 )
local Player = getLocalPlayer()

addEventHandler("onClientResourceStart", resourceRoot,
function()
local screenW, screenH = guiGetScreenSize()
zerowanie_g = g...
28. Pojazdy się nie respią [ DayZ ]
Witam. Naprawi mi ktoś ten kod ? Bo próbowałem wszystkiego i nadal tego nie moge zrobić. Jeżeli ktoś to ogarnia prosze po POMOC !
--SERVER[lua] OUTPUTS
shownInfos = {}

shownInfos["nomag"] = "Sem munição!"
shownInfos["youconsumed"] = "Comeu ou Bebeu :"
shownInfos["needwatersource"] = "Você precisa estar nadando!"
shownInfos["filledup"] = "Você encheu a sua Garrafa de Água!"
shownInfos["noradio"] = "Você não Radio Device filho!"

--GAMEPLAY SETUP
gameplayVariables = {}

gameplayVariables["zombieblood"] = 10 -- Zombie Blood/Health - DEFAULT: 6000
gameplayVariables["foodrestore"] = math.random(40,100) -- Amount of hunger to be restored when eating - DEFAULT: math.random(40,100) - FOR FULL RESTORE, JUST WRITE 100
gameplayVariables["thirstrestore"] = math.random(40,100) -- Amount of hunger to be restored when drinking - DEFAULT: math.random(40,100) - FOR FULL RESTORE, JUST WRITE 100
gameplayVariables["loseHunger"] = -1.5 -- Amount of losing hunger per minute - DEFAULT: -1.5
gameplayVariables["loseThirst"] = -1.5 -- Amount of losing thirst per minute - DEFAULT: -1.5
gameplayVariables["playerzombies"] = 6 -- Amount of spawning zombies per player - DEFAULT: 6 - THE HIGHER THIS VALUE, THE MORE LAG CAN OCCUR!
gameplayVariables["amountzombies"] = 4 -- Amount of...
29. [MYSQL] baza danych nie wyszkuje
Siema moja baza dostała raka bo nawet po wpisaniu czegoś takiego jak SELECT * FROM tabela WHERE cośtam = costam nie pokazuje danych a puste tabelki nie mówiąc już o zapytaniach które lecą z mapy.
30. Nie odczytuje include
Witam, mam problem bo mam include, ale wyskakuje mi taki błąd

Pawn

Current directory
C:UsersSMv2Desktop
C
:UsersSMv2DesktopPliki serwerowe SAMPwxcincludeYSI/y_ini.inc(165) : fatal error 100cannot read from file"y_utils"

Compilation aborted.Pawn compiler 3.2.3664              Copyright (c1997-2006ITB CompuPhase


1 Error
.
================ 
READY ================


Mam include w folderze "Pliki serwerowe SAMP >> wxc >> include >> YSI >> mam tam i y_ini.inc i y_utlis.inc no i nie wiem o co kaman ;/
31. GetObjectRot nie działa
Witom mam problem ,zrobiłem sobie system mebli i zrobiłem co 1 sekunde zapis pozycji który wyglada tak:
Pawn

    GetObjectPos
(Mebel[idobj] ,,,Z);
    
dini_FloatSet(ladowanie ,"pozycja x" ,X);
    
dini_FloatSet(ladowanie ,"pozycja y" ,Y);//pozycja
    
dini_FloatSet(ladowanie ,"pozycja z" ,Z);

i to działa dobrze ale zapis rotacji
Pawn

    GetObjectRot
(Mebel[idobj] ,RX ,RY ,RZ);
    
dini_FloatSet(ladowanie ,"rot x" ,RX);
    
dini_FloatSet(ladowanie ,"rot y" ,RY);//rotacja
    
dini_FloatSet(ladowanie ,"rot z" ,RZ);

a do pliku zawsze rotacje zapisuje 0.00000000 ??
Ładowanie wiem ze działa bo dałem takie cos
Pawn
printf("zapisalem id %i rotacja %i ,%i ,%i" ,idobj ,RX ,RY ,RZ);

i w konsoli wychodzi
Kod:

zapisalem id 2 rotacja 0 ,0 ,0


POMOCY
32. [MTA] Gracze nie mogą wejśc na ser
Witam ostatnio gracze na moim serwerze maja problemy z dołączeniem.
Kod:

Błąd pobierania: Error downloading requested files. Couldn't connect to server. [Failed connect to 188.68.249.251:20429; Connection refused] [AQL-Licznik/client.lua]
33. Po zalogowaniu nie respi
Witam! Mam paczkę Play Your Stories, loguje się lecz jest czarny ekran i chat. Na chacie mogę pisać itp. W WYBORZE SPAWNU WYBRAŁEM SPAWN
34. nie działa panel logowania
[lua][/lua[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:20: Bad argument @ 'dbPrepareString' [Expected db-connection at argument 1, got nil]
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:21: Bad argument @ 'dbQuery' [Expected db-connection at argument 1, got nil]
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:22: Bad argument @ 'dbPoll' [Expected db-query at argument 1, got boolean]
[2016-12-25 17:16:52] ERROR: MNS-Core/core_s.lua:36: attempt to get length of local 'result' (a boolean value)
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:20: Bad argument @ 'dbPrepareString' [Expected db-connection at argument 1, got nil]
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:21: Bad argument @ 'dbQuery' [Expected db-connection at argument 1, got nil]
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:22: Bad argument @ 'dbPoll' [Expected db-query at argument 1, got boolean]
[2016-12-25 17:16:52] ERROR: MNS-Premium/custom.lua:28: attempt to get length of local 'x' (a boolean value)
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:20: Bad argument @ 'dbPrepareString' [Expected db-connection at argument 1, got nil]
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:21: Bad argument @ 'dbQuery' [Expected db-connection at argument 1, got nil]
[2016-12-25 17:16:52] WARNING: MNSDB/s_db.lua:22: Bad argument @ 'dbPoll' [Expected db-query at argument 1, got boolean]
[2016-12-25 17:16:52] ERROR: MNS-Premium/custom.lua:194: attempt to index local 'org' (a boolean value)


Nie działa mi panel logow...
35. EazyWorkshop nie dodaj MK
Witam poszukuje tutaj odpowiedzi na moje pytanie dlaczego w eazyWorhshop nie dodaje mk zabiera kase ale nie dodaje i nwm czym to jest spowodowane ?
36. [MTA] nie moge zainstalowac
elko.
mam taki problem,gdy chcę zainstalować mta:

Rozpakuj,błąd zapisu do pliku:
D/Users/uzytkownik/AppData/Local/Temp/nsm23F8.tmp/NSIS.dl.dll

jak to zaakceptuje,to potem pojawia się ten sam błąd tylko z plikiem nsDialogs.dll

a jak to tez zaakceptuje,to jak dam zainstaluj pojawia sie błąd:

Rozpakuj,błąd zapisu do pliku dxwebsetup.exe

wynagrodzę piwem za pomoc
37. Nie wczytuje modelu
Witajcie wymodelowalem remize psp(tak dla testu) i wgrałem ją na serwer ale nie chce się załadować cały w podmienianiu nie ma żadnego błędu a nadal jest tylko w połowie wczytany.
SS:

38. Nie tworzy napisu
Witam!
Robiąc jedną cmd a mianowicie teleport do siłowni w ls chciałem stworzyć także napis na mapie.

Robie tak :
Kod:

CreateDynamic3DTextLabel("{1E90FF}Siłownian{FF0033}>-> Wejscie <-<",0x008080FF,2227.1682,-1723.5931,13.5520, 200.0, INVALID_PLAYER_ID, INVALID_VEHICLE_ID, 0, 0, -1, -1, 200.0);

Lecz gdy odpalam mapke teleportuje się na siłownie żaden napis nie powstaje.

Za pomoc poleci piwko!


[ Dodano: 2016-12-23, 17:40 ]
Dodam że nie ma żadnego błędu w kom. pawno jak i w samej konsoli.
39. Taser nie dziala
Witam pomozecie mi bo nie wiem dlaczego mi nie dziala ten skrypt, kiedys normalnie dzialal a dzisiaj nie chce wogole, nic sie nie dzieje po strzale z paralizatora.

addEventHandler("onPlayerDamage"getRootElement(), 
function(
attackerweaponbodypartloss
if 
weapon == 23  then
setElementFrozen 
sourcetrue )
setElementHealth(source100
setPedAnimation(source"ped""cower", -)
toggleAllControls(sourcefalse)
setTimer(setElementFrozen,150001sourcefalse)
setTimer(setPedAnimation150001source)
setTimer(toggleAllControls150001sourcetrue)
end
end
)
40. [GTAIV] Nie włacza sie Gta 4
Cześć , kupiłem dziś gta 4 i mam następujące problemy :

-Nie mogę się zalogować na Rockstar Games Social ( nie na stronie tylko jak wlaczam gta 4 )
-Jak próbuje przez ikone lub lunche to pokazuje okienko jakies i znika .
Oczywiście Gta oryginalne
Proszę o poradę czy pomoc. Oferuje respekt i piwerko zimne za to ;)




phpBB by Przemo modified by xXx 2003-2016

Template GTAONLINE created by gtaonline.pl



Strona wygenerowana w 0,79 sekundy. Zapytań do SQL: 8